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What is Easy Menu?
Easy Menu for Windows is used to start applications or desktop accessories in Microsoft 
Windows 3.X.    It makes user-specified applications available with a single click of the mouse
or press of a key.    In addition, it makes all of the Windows Desktop Accessories or user-
defined accessories available on the same menu.    Applications may be Windows or DOS 
programs.    Version 5.0 is fully compatible with Windows 3.1 and later (and will not run 
under previous versions of Windows).    Easy Menu for Windows 4.0 runs in Standard and 
Enhanced mode.    Easy Menu for Windows has complete keyboard support, so it is an 
excellent Windows applications manager for laptops and other systems without a mouse.



What's New in Version 5.0?
Version 5.0 of Easy Menu for Windows is a major upgrade from previous versions.    Among 
the new features are:

· The six menus are now displayed in the Easy Menu window as 3D tabs.    To change 
menus, simply click the appropriate tab.

· Easy Menu now includes an activity log, which records to a file all of the actions you 
take to start applications and accessories.    The log can be used to track your 
computer use and to diagnose problems.

· All configuration and setup of menus is completed from within Easy Menu.    All other 
setup (such as system shell, auto-start, etc.) is also completed within Easy Menu.

· The Command Bar buttons can be configured with the commands you use the most.
· Alternate program and file managers can be specified by the user.
· Start-up directories can be specified for Windows Desktop accessories and user 

accessories.
· Easy Menu has extensive on-line help, including context sensitive help in dialog 

boxes.    The on-line help replaces the User's Manual.  The Easy Menu Help 
includes a complete keyboard diagram for users working without a mouse.

· Verification of user passwords has been added.



Quick Start
There are just a few simple steps to get Easy Menu up and running:

1.    Create the first menu by clicking any of the menu tabs while holding down the SHIFT 
key, and entering a menu name in the first edit box.    Click the OK button.

2.    Add a menu item to the first menu by clicking the 1 pushbutton on the menu while 
holding down the SHIFT key.    Enter a label, command line, and start-up directory in 
the edit boxes.    If you don't know the name of the program to run, use the Browse 
button to search your disk.    Click the Save button.

3.    Click the 1 pushbutton to start the application you just set up!    That's all there is to 
it.

Now you can create all of the other menu items and additional menus.



Application Window Overview
The Easy Menu window is composed of a number of distinct areas, each of which has a 
specific function.    The areas are shown below.    Click on each area in the window for more 
information.



Menu Organization
With Easy Menu you can construct up to five menu groups, each with six menus, with 10 
items in each menu.    How you organize your menus will determine how easy Easy Menu is 
to use.    The suggested organizations below are only some of the ways you might want to 
consider.
Menu Groups
Menu groups are designed to give you more flexibility in organzing your menus.    If you need
to start more than 60 applications you can create groups of menus, giving you up to 300 
menu choices.    Easy Menu supports up to five groups of six menus each.    Creating multiple 
groups is also useful if more than one person uses a computer -- each person can be given 
their own group of menus.    Within each group, you can also provide some organization to 
the menus as described below:
Organizing by Type of Application
One way to set up the Easy Menu menus is to have each menu contain different types of 
applications.    Menu 1 might contain word processing and text editing applications, for 
example, while Menu 2 could contain speadsheet and database programs.    Menu 3 could 
have drawing, graphics, and presentation applications.    Menu 4 might contain 
entertainment and game programs.
Organizing by Task
Another way to organize your menus is by the tasks you complete.    This type of 
organization is useful if you want to use the same applications for several menu items, but 
with different start-up files (as command line parameters) or start-up directories.    For 
example, a small consulting firm might have one menu for each current project.    Each menu
would contain a word processing menu item, a project management item, a speadsheet 
item, and a desktop presentation item.    The menu items would have different start-up 
directories which were created for the exclusive use of the appropriate project.    When the 
applications are started, the current working directory would be the directory for the desired 
project.
Organizing Sequentially
If you do not have many applications, it may be more useful to simply list the applications 
alphabetically in the first couple of menus.    When the first menu is full, go on to the next 
and continue with the listing.    With the menu tabs you will have a quick and easy way to 
access all of your menu items.



Technical Support
Technical support is available from the author on Compuserve:    71401,2413.    When you 
report a problem, be as specific as you can and include the following information:    your 
name, Easy Menu license number, phone number, type of computer, video card and 
monitor, DOS and Windows version numbers, other software running when you had a 
problem, and the exact nature of the problem you are experiencing.

Also, you can report any problems or suggest improvements for future versions by writing 
to:
Glen S. Tittermary
P.O. Box 1641
Richmond, Virginia 23213



Error Messages
Too many clocks or timers.

This error means that too many programs which use the Windows timer (such as the Clock) 
are currently running.    Easy Menu needs one of the timers to display the current date and 
time.    Close one of the applications and try to restart Easy Menu.

The specified start-up directory is invalid.

The start-up directory that you entered for the application does not exist.    You may have 
misspelled it when entering it.    Change the start-up directory to a valid DOS directory.

The specified start-up drive is invalid.

You specified a disk drive in the start-up directory that does not exist.    Change the start-up 
drive to a vaild drive on your system.

Insufficient memory to run application.

There is not enough memory to run the application.    If other applications are running, try 
closing some of them to free some memory.

Invalid path or filename.

The path or filename that you specified in the command line is invalid.    You may have 
misspelled it.    Enter the correct path and filename for the application you want to run.

Unable to execute application.

Easy Menu has encountered some problem while trying to execute the application.    Close 
other applications, and be sure your command line is correct.

Unable to execute accessory.

Easy Menu has encountered some problem while trying to execute an accessory.    If the 
accessory is a Windows Desktop Accessory, it probably is not in the Windows directory; be 
sure the accessories are properly installed in the Windows directory.    If it is a user 
accessory, you may have misspelled the accessory program name when setting it up or it is 
not in the Windows directory; use the accessories setup dialog box to check the information 
you supplied and enter a path in the command line if necessary.

Program Manager is already running.

You tried to start the Program Manager when it was already running.    Use the Task List to 
activate the Program Manager.

File Manager is already running.

You tried to start the File Manager when it was already running.    Use the Task List to 
activate the File Manager.

Incorrect license number entered.

The license number you entered was not valid.    Be sure you typed the number exactly as 



listed on the registration notification.    Contact the author if the your license cannot be 
entered.

Invalid password after three attempts.    Cancelling current task.

The password has been entered incorrectly three times.    After the third try, Easy Menu 
cancels the requested task.

Invalid password.    Cannot start Easy Menu.

Password protection has been applied to Easy Menu start-up and the correct password was 
not entered.    Easy Menu cannot be started.

Selected drive is removable.    Please insert diskette now.

You have requested a file operation for a diskette drive (a: or b:).    This is a reminder to be 
sure a diskette is in the drive.

Source file cannot be opened.    File operation halted.

Easy Menu could not find or could not open the specified file.    You may need to specify a full
path the file or make sure it is not read-only.

Cannot copy or move a file to itself.    Select a new Target Directory.

You tried to copy a file but did not change the target directory.    Change the directory you 
are to copy the file to.

File already exists in Target Directory.    Overwrite existing file?

This message is asking for confirmation to overwrite a file with the same file name as the 
one you are copying or moving.

Target file cannot be created.    File operation halted.

Easy Menu was unable to create the file you specified.    Check to make sure it was a valid 
DOS filename, or that your disk is not full.

File could not be deleted.

Easy Menu was unable to delete the file you specified.    Make sure you specified the file 
name correctly and that the file is not read-only.

Directory could not be created.

Easy Menu could not create the new subdirectory you requested.    Make sure that you 
specified a proper DOS directory name and that the directory does not already exist on the 
specified drive.

Cannot access printer driver.

This error occurs if Easy Menu is unable to determine the type of printer you are using.    This
information is contained in the "win.ini" file under the [Windows] section in a field labeled 
"devices=."    Use the Control Panel to set up a default printer.



Unable to start print job.

Easy Menu was unable to initialize the printer spooler.    Be sure that the Print Manager is 
properly installed.

See also:    Windows execution errors



Application Execution Errors
One of the following file errors is listed in the Activity Log whenever Easy Menu is unable to 
execute an application.    Use these error messages to help you diagnose problems you have 
running a program:

Error Code Meaning

0 Out of memory

2 File not found.

3 Path not found.

5 Attempt to dynamically link to a task.

6 Library requires separate data segments for each task.

10 Incorrect Windows version.

11 Invalid .EXE file.

12 OS/2 application.

13 DOS 4.0 application.

14 Unknown .EXE type.

15 Attempt to load an old Windows program in protected mode.

16 Attempt to load second instance of .EXE file when not suppported.

17 Attempt to load a second instance that links to non-shareable DLL.

18 Attempt to load protected mode application in Windows real mode.



Setting Minimize on Run
To make Easy Menu minimize each time you run an application or accessory:

1.    Select Minimize on Run from the Options menu.    A check mark will appear next to 
Minimize on Run when the option is active.

To turn the minimize option off:

1.    Select Minimize on Run again.    The check mark will be removed when the option is 
not active.



Entering Your Name and License Number
To order your license:

1.    Print the order form included in this help file.

2.    Fill out the form completely, and be sure to mark a disk size if you are ordering a 
diskette.

3.    Include your payment (check or money order).    The license fee is $20, and a diskette 
with the program and help files is an additional $5.    See the order form for site 
license fees.

4.    Mail to the address on the order form.

To enter your name and license:

1.    Start Easy Menu and the Enter License... dialog box will appear.    (The license number
removes the license dialog box which appears when Easy Menu for Windows is 
started.)    Note:    After Easy Menu has been started, you can also enter your name 
and license by selecting the Enter License... item from the Options menu.

2.    Type your full name in the first edit box.

3.    Type your license number in the second edit box exactly as it appears on    your 
registration notification (capital letters must be typed as capitals, etc.).

4.    If you are using a mouse, click the OK button.    If you are using the keyboard, press 
the TAB key to move the focus to the OK button, then press the SPACE BAR.



Saving the Window Position
By default, the Easy Menu window will center itself on the screen.    You can override this 
default and keep Easy Menu in any location on your screen.

To save Easy Menu in a location you want.:

1.    Move Easy Menu to the position you want on the screen by dragging the title bar.

2.    Select Window Position Save under the Options menu.    The position you selected will 
be saved, and used whenever you start Easy Menu.

To return to the default:

1.    Select Window Position Center from the Options menu.



Setting the System Shell
When you installed Windows, Program Manager was set up as the system shell.    But you 
can select other programs as shells if you wish.    If you decide to use Easy Menu for 
Windows on a regular basis you can set it as the shell.

To set the Windows shell:

1.    Select Setup System Shell... in the Options menu.

2.    In the System Shell dialog box, click the radio button for the shell you want.    If you 
are using the keyboard, use the up and down arrow keys to change the selection.

3.    Click the OK button, or press ENTER.    The new shell will be effective the next time 
you start Windows.



Setting Up Applications for Auto Start
If you select Easy Menu as the system shell, you can specify that certain applications run 
when you start Windows.    Five applications can be started as full windows and an additional 
five applications can be started as icons.    "Load" and "run" options in WIN.INI are not run on
startup.

To configure the applications to run automatically whenever Windows is started:

1.    Select Setup Auto Start... from the Options menu.

2.    In the appropriate edit boxes in the Auto Start dialog box, type the program 
executable file names you want to run and to load as icons.    Remember, if a program
is not in a directory specified in your path statement, you will need to enter a 
complete path and filename in the Auto Start dialog box (and it's preferable to enter 
the complete path anyway, because the application will load faster).    You can enter 
any valid command line, including switches, startup files, etc.    Move from one field to
the next by pressing the TAB key.

3.    Click OK or press the RETURN key to save your configuration.



Setting Up the Command Buttons
To set the commands to be executed from the Command Bar:

1.    Select Setup Command Buttons... from the Options menu.    (Or click any Command 
Bar button while holding down the SHIFT key.)

2.    When the Command Buttons dialog box opens, select a command from the list box.

3.    Click the button to which you want to assign the command.

4.    Click the Save button to save the change and close the dialog box.    If you are using 
the keyboard, use the TAB key to move the focus to the Save button and press the 
SPACEBAR.



Specifying Alternate System Managers
You start Program Manager and File Manager with the pushbuttons on the Command Bar.    
Normally, the system managers shipped with Windows are started.    However, you can 
specify that alternate system managers start when the Program or File buttons are clicked.

To specify the alternate managers:

1.    Select Setup Alternate Managers... from the Options menu.    (Or, click the Program 
or File buttons while holding the SHIFT key down.)    The Alternate System Managers 
dialog box is displayed.

2.    Type the name(s) of the new program and/or file managers you want in the 
appropriate edit boxes.    Use a full path name if the program is not in a directory in 
your PATH statement.

3.    Click the OK pushbutton, or press the ENTER key.



Creating/Editing Groups
To create or edit a group:

1.    Select Edit Group Names... from the Group menu.    The Group Names dialog box will 
be displayed.

2.    For each group you want to create or edit, type the name of the group in the 
appropriate edit box.

3.    Click the OK pushbutton or press the ENTER key to save the new group names.

To add menus to a new group, select the group just created from the Group menu.    Easy 
Menu will display an empty menu which can be edited with the Menu Names dialog.    See 
Creating/Editing Menus for more information.

To delete an existing group:

1.    Delete the name in the edit box.

2.    Click the OK pushbutton or press the ENTER key to save the deletion.    (Note:    All the
menu data associated with the group is retained so you can reenter a group name 
later to use the menus in the group.)



Selecting a Group
When Easy Menu first starts, Group A will be active.    You can change the active group from 
the Easy Menu menu bar or the keyboard.

To select a group using the menu bar:

1.    Choose the Group item on the menu bar.    The groups which have been created will 
be displayed in the drop-down menu.

2.    Select the group you want to load.    The currently selected group will have a check 
mark next to it.    When a new group is selected, Easy Menu will be updated to display
the menu tabs associated with the group.    The first menu in the group will be active.

To scroll through the available groups:

1.    The keyboard can be used to scroll through the groups with the PgUp and PgDn keys 
to select the previous and next group respectively.

NOTE:    You will only be able to scroll through groups if more than one group has been 
created.    See Creating/Editing Groups.



Creating/Editing Menus
To create or edit a menu:

1.    Select Edit Menu Names... from the Menu menu.    (Or click any of the six menu tabs 
while holding down the SHIFT key).    The Menu Names dialog box will be displayed.

2.    For each menu you want to create or edit, type the name of the menu in the 
appropriate edit box.

3.    Click OK to save the new menu names.

To add menus items to a new menu, select the menu just created by clicking the tab for the 
menu.    Easy Menu will display the menu.    While holding the SHIFT key down, click the 
button for the item you want to create to display the Menu Items dialog.    See 
Creating/Editing a Menu Item.

To delete an existing menu:

1.    Delete the name in the appropriate edit box.

2.    Click the OK pushbutton or press the ENTER key to save the deletion.    (All the menu 
data associated with the menu is retained so you can reenter a menu name later to 
use the menu items.)



Selecting a Menu
When Easy Menu first starts, Menu 1 of Group A will be active.    You can change the active 
menuwith the Easy Menu tabs, the menu bar, or the keyboard.

To select a menu using the tabs:

1.    Click the tab once.    The menu associated with the tab will be brought forward and 
made active.

NOTE:    You will not be able to select a grayed "Reserved" tab.

To select a menu using the menu bar:

1.    Choose the Menu item on the menu bar.    The menus which have been created will be
displayed in the drop-down menu.

2.    Select the menu you want to load.    The currently selected menu will have a check 
mark next to it.    When a new menu is selected, Easy Menu will be updated to display
the menu items associated with that menu.

To scroll through the available menus:

1.    The keyboard can be used to scroll through the menus one at a time.    Use the down 
or right arrow keys to select the next menu; use the up or left arrow keys to select 
the previous menu.

NOTE:    You will only be able to scroll through menus if more than one menu has been 
created in the currently selected group.    See Creating/Editing Menus.



Starting an Application on the Menu
To start an application from the menu using the mouse:

1.    Click the associated pushbutton on the Application Menu.

To start an application using the keyboard:

1.    Press the number key corresponding to the menu pushbutton.



Creating/Editing a Menu Item
You create new menu items and edit exiting items in the Menu Items dialog box.    For each 
menu item you supply a label, command line, and start-up directory.    You also specify 
whether the application should start as a window, an icon, or full screen.

To create or edit a menu item:

1. Hold down the SHIFT key on the keyboard and click the button for the menu item you 
want to create or edit, or press the corresponding number key on the keyboard.    
(Unused menu items will be labeled Reserved.)    For example, it you want to create or
edit a menu item for the number 4 button, click the 4 button while holding the SHIFT 
key down, or press the 4 key with the SHIFT key down.

2. When the Menu Item dialog box opens, type in the item label that you want to appear
beside the pushbutton.

3. Using the mouse or TAB key, move to the Command Line field.    Type the command 
line for the application.    If you do not know the name of the executable file, click the 
Browse button to the right of the Command Line field.    You can then search your 
drives and directories to select the file you want.

4. Using the mouse for TAB key, move to the Start-up Directory field.    Type the name of 
the directory you want as the initial directory when the application starts.    If you do 
not know the name of the directory, click the Browse button to the right of the Start-
up Directory field.    You can then search your drives and directories to select the 
directory you want.

5. Using the mouse for TAB key, move to the Start As radio buttons and select how you 
want the application to start:    as a window, an icon, or full screen.    Click a button 
with the mouse or use the arrow keys to move to another button.

4. Click the Save button to save the menu item and return to Easy Menu.

At any time, you can undo your edits to a menu item by clicking the Undo pushbutton.    For 
a new item, Undo returns all of the edit fields to their defaults (Reserved, none, none, 
Window).    For an item you are editing, Undo returns the edit fields to their original data 
before you started the edit.    All edit fields can be set to the defaults with the Clear 
pushbutton, effectively deleting the menu item.    (The Undo button will recover the original 
label, command line, and start-up directory.)

Before you Save the menu information in the Menu Item dialog you can use the Test 
pushbutton to determine if the information you supplied can be used by Easy Menu to 
execute the application in the way you intended.    When you click the Test pushbutton, Easy
Menu performs the following tests:    (1) parses the item label so you can see how it will 
appear on the menu, (2) determines if the command line executable file can be found, (3) 
checks the start-up drive and directory to determine if they actually exist on your disk, (4) 
checks the start-as mode to make sure that an appropriate mode is specified in the 
"menu.ini" file, and (5) parses the command line parameters so you can see them in the 
final test report.    After the test is complete, a report dialog box will be displayed.    Any 
potential errors in your menu data will be reported.



Printing a Menu
To print the currently selected menu:

1.    Select Print Current Menu from the Menu menu.    Easy Menu prints to the default 
printer for Windows, using the current settings for the printer.



Setting Up the Windows Accessories
On some occasions it may be useful to have the Windows Desktop Accessories load an initial
file when they are started.    This is especially useful for an accessory such as Calendar, for 
which you would normally use the same calendar file each time it is started.      Or it may be 
useful to start with a specific directory active

To specify initial files for the accessories:

1.    Select Setup Windows Accessories... from the Options menu.    (Or, when the Windows
Accessories are selected in the Accessories Menu, click any of the accessory buttons 
while holding the SHIFT key down.)    The Initial Accessory File dialog box will be 
diplayed.

2.    For each of the accessories listed, type in the file you want to have loaded when the 
accessory starts.    You can use the TAB key to skip down to the next item.    You do not
have to specify a file for all of the accessories, only for the ones you want to open an 
initial file.

3.    Click the OK pushbutton or press the ENTER key to save your set-up to the "menu.ini"
file.    Click Cancel if you want to exit without saving the changes.

To cancel the settings for the initial file:

1.    Select Setup Windows Accessories... from the Options menu.    (Or, when the Windows
Accessories are selected in the Accessories Menu, click any of the accessory buttons 
while holding the SHIFT key down.)    The Initial Accessory File dialog box will be 
diplayed.

2.    Delete the filename specified in the appropriate edit box in the Initial Accessory File 
dialog box.

3.    Click the OK pushbutton or press the ENTER key to save the deletion.

To specify a start-up directory:

1.    Select Setup Windows Accessories... from the Options menu.    (Or, when the Windows
Accessories are selected in the Accessories Menu, click any of the accessory buttons 
while holding the SHIFT key down.)    The Windows Accessory Setup dialog box will be 
diplayed.

2.    In the Start-up Directory edit boxes enter the full path for the directory you want 
associated with each accessory.    You do not need to enter a directory for all of the 
accessories, only the ones you want to open in a specific directory.    (The default is 
for the accessories to open with the Windows directory active.)

3.    Click the OK pushbutton or press the ENTER key to save your set-up to the "menu.ini"
file.    Click Cancel if you want to exit without saving the changes.



Setting Up the User Accessories
The Accessories Menu can be configured with either the Windows Desktop Accessories or 
with nine accessories which you define.

To set up your own set of accessories:

1.    Select Setup User Accessories... from the Options menu. (Or when the user accessory 
buttons are active in the Accessories Menu, click any of the button while holding 
down the SHIFT key.)

2.    In the User Accessories Setup dialog box, enter the names to appear on the faces of 
the pushbuttons in the Button Label: edit boxes.

3.    Enter the command lines to be executed when the buttons are clicked in the 
Command Line: edit boxes.    The command line can consist of an executable file 
name plus any command line parameters, including a file to open when the 
accessory starts.

4.    When Easy Menu starts the user accessories it assumes they are in your Windows 
directory.    If your accessories are elsewhere, you will need to specify a start-up 
directory in the Start-up Directory: edit boxes..

5.    Once you have defined all of the accessories you want, click the OK pushbutton or 
press the ENTER key.

NOTE:    Each accessory you define is assigned to one of nine function keys.    When the 
Accessories pushbutton menu is active in Easy Menu and the user accessories are selected, 
you can use the assigned function key to start the accessory.



Selecting Windows or User Accessories
Easy Menu supports two types of accessories:    (1) those supplied with Windows, and (2) 
utilities which the user supplies from other sources.    You select which type of accessories 
can be started from the Accessories Menu.

To use the Windows Desktop Accessories:

1.    Select Windows Accessories... from the Options menu or click the w tab to the right of
the Accessories Menu.

To use the nine user-defined accessories:

1.    Select User Accessories... from the Options menu or click the u tab to the right of the 
Accessories Menu.

To toggle between the Windows and user-defined accessories:

1.    You can toggle between the Windows and user-defined accessories by pressing the 
SPACEBAR when Easy Menu is the active window.



Starting the Windows Desktop Accessories
If you have the Accessories Menu configured for the Windows Desktop Accessories, you can 
start the accessories in several different ways.

To start a Windows Desktop Accessory:

1    Click on the appropriate button on the Accessories Menu.    Or, select the accessory 
from the Accessories menu on the Easy Menu menu bar.    To use the keyboard, press 
the letter key corresponding to the pushbutton.    The appropriate letter is the one 
underlined in the pushbutton.



Starting the User Accessories
If you have the Accessories menu configured for the accessories you have defined, you can 
start the accessories in several different ways.

To start a user-defined accessory:

1    Click on the appropriate button on the Accessories Menu.    Or, select the accessory 
from the Accessories menu on the Easy Menu menu bar.    To use the keyboard, press 
the function key (F1, F2, F3, etc.) assigned to the accessory when it was set up in the 
User Accessories dialog.



Starting an Application Not on a Menu
On occasion you may want to run an application not on an Applications Menu.

To type and run a command line:

1.    Select the Quick Run... item from the File menu.    Or, you can click the Run button if it
is one of the commands you have placed on the Command Bar.    If you are using the 
keyboard, press the Q key.

2.    When the Quick Run dialog box appears, type the command line you want.

3.    Click the OK button or press the RETURN key.

NOTE:    You can search for an executable file to run using the Browse pushbutton.



Copying/Moving a File
To copy or move a file:

1.    Select the Copy/Move item from the File menu.    The File Copy/Move dialog box will be
displayed.

2.    Select the file to copy by highlighting it in the list box in the lower left hand portion of 
the dialog box.

3.    Click the Select File button.    (You can move from one directory to another within the
list box by highlighting the name of the directory and clicking the Change Directory
button.)    The name of the selected file will be displayed in the From: text box at the 
top of the dialog, and the To: list box in the lower right hand portion of the dialog will 
be enabled.    The From: list box will be disabled.

4.    Select the drive and directory where you want to copy the file to.    (You can move to 
other directories by highlighting the directory name and clicking the Change 
Directory button.)    The currently selected directory will be displayed in the To: text 
box at the top of the dialog.

5.    To carry out the copy operation, click the Execute button.    After the copy is complete
a message box will notify you.

If you make a mistake in specifying any of the information for the copy you can clear all your
entries and start over by clicking the Reset button.    After you have copied all the files, click
on Close to return to Easy Menu.

To move a file, follow the steps above for copying a file, but click the Move radio button 
before clicking the Execute button.



Deleting a File
To delete a file:

1.    Select Delete from the File menu.    The File Delete dialog box will be displayed.

2.    Type the name of the file to be deleted in the edit box.

3.    Click the Delete button.

If you do not know the exact name of the file, click the Browse button to open the File 
Browse dialog box, which will have a listing of all the files in the currently selected directory.  
In the File Browse dialog, highlight the file to be deleted in the Files: list box and click the 
Select button.    The file name will be copied to the File Name: edit box.    Click the Delete 
button to delete the file.

NOTE:    You can delete a file only in the current directory, which is shown above the edit box 
for the file name.    If you need to change directories, click on the Browse button to display 
the File Browse dialog box.    In the Directories: list box, double-click the directory you want.
You can also change drives with the Drives: combo box.



Renaming a File
To rename a file:

1.    Select Rename from the File menu.    The Rename File dialog will be displayed.

2.    Type the file's current name in the From: edit box at the top of the dialog.

3.    Type the new file name in the To: edit box.

4.    Click the Rename button to carry out the rename operation.

If you do not know the exact name of the file to rename, click the Browse button to open 
the File Browse dialog box, which will have a listing of files in the currently selected directory.
In the File Browse dialog, highlight the file to be renamed in the Files: list box and click the 
Select button.    The file name will be copied to the From: edit box and the focus moved to 
the To: edit box ready for the new file name.

NOTE:    You can rename a file only in the current directory, which is shown above the edit 
box for the file name.    If you need to change directories, click on the Browse button to 
display the File Browse dialog box.    In the Directories: list box, double-click the directory 
you want.    You can also change drives with the Drives: combo box.



Creating a Directory
To create a new subdirectory on your hard disk:

1.    Select Create Directory from the File menu.    The Create Directory dialog box will be 
displayed.

2.    Type the new subdirectory name in the edit box.

3.    Click the Create button.    The new directory will be created in the current directory, 
which is shown above the edit box at the top of the dialog.

If you need to change to a different directory, click the Browse button to display the 
Directory Browse dialog box.    To change directories, double-click the directory in the list 
box.    The current directory will be shown above the list box.    When you have the directory 
you want, click the Select button or press the ENTER key.



Using the File Browser
The File Browser is used to find files for the Menu Item, QuickRun, File Delete, File Rename, 
etc, dialog boxes.

To use the File Browser to find a file:

1.    Click the Browse pushbutton in any dialog box where it is available.    The File Browse
dialog is displayed

2.    Select the file you want in the Files: list box.

3.    Click the Select pushbutton, or press the ENTER key.    The name of the selected file 
will be pasted to the edit box of the source dialog.

To change directories within the File Browse dialog box:

1.    Double click the name of the directory in the Directories: list box, or select a 
directory and click the Change Directory pushbutton.    Select [..] in the 
Directories: list box to move up one step in the directory tree.    You can also change
drives by selecting a new drive letter in the Drives: combo box.



Using the Directory Browser
The Directory Browser is used to select an existing directory for the Menu Item and Create 
Directory dialog boxes.

To use the Directory Browser to select a directory:

1.    Click the Browse pushbutton in the Menu Item or Create Directory dialog boxes.    The
File Browse dialog is displayed

2.    Select the directory you want in the Directories: list box.

3.    Click the Select pushbutton, or press the ENTER key.    The full path of the selected 
directory as it appears in the text box will be pasted to the edit box of the source 
dialog.

To change directories within the File Browse dialog box:

1.    Double click the name of the directory in the Directories: list box, or select a 
directory and click the Change Directory pushbutton.    Select [..] in the 
Directories: list box to move up one step in the directory tree.    You can also change
drives by selecting a new drive letter in the Drives: combo box.



 Getting System Information
Sometimes it is useful to get information about your system, such as how much free 
memory or disk space is currently available.

To get a report on system information:

1.    Select System Info... from the Help menu.    You can also set up an Info button in the 
Command Bar.    The System Information dialog box opens and displays the following 
information:

· The current version of Windows.
· Whether Windows is operating in Standard or 386 Enhanced mode.
· The type of microprocessor in your system.
· Whether a math coprocessor is present in the system.
· Whether a mouse is installed.
· The display resolution for your system.
· The number of colors which Windows will display on your system.
· The amount of free memory in the system.
· The percentage of free system resources.
· The amout of free disk space on the currently selected drive.

2.    Click the OK button or press the ENTER key to close the dialog box.



 Using System Security
The System Security... item on the Options Setup menu provides several methods for you to 
protect your system and data.    You can set up password protection for various tasks, and 
you can set attributes for key system files.    These features provide basic security for your 
siystem, and can be especially useful if you are using a network or are in a    office in which 
others may have access to your computer.

You can also optionally apply the password to the start-up of Easy Menu (and to Windows 
ifself if Easy Menu is the shell), the start-up of each application on the menu, the start-up of 
the Program and File Managers, and the use of the Windows and user accessories.    Note 
that if you apply the password to the Easy Menu start-up, you will have to also type your 
password to close Easy Menu (or your Windows session if Easy Menu is the shell).    This is 
useful in preventing someone from ending your Windows session in order to get access to 
the DOS prompt.

The System Security... dialog box also provides a means to protect critical system files.    Five
files can be made read-only and/or hidden:    config.sys, autoexec.bat, win.ini, system.ini, 
and menu.ini.    Making the files hidden will keep others from finding the files on directory 
listings.    Making them read-only keeps them from being accidentally erased or modified.    
Note, however, that making win.ini, system.ini, or menu.ini read-only means you will not be 
able to save any changes to your Windows configuration.    Also programs such as Excel and 
Word save their configurations to win.ini when they exit;    if win.ini is read-only protected, 
you may get an error message.    In addition, many programs must write to win.ini or 
system.ini when they are installed.    Read-only protection should be turned off before 
installing any new applications in Windows.

To create a password:

1.    Select System Security... from the Options Setup menu.    The System Security... dialog
box will be displayed.

2.    Click the Set Password... pushbutton.    The Password... dialog will be displayed.

3.    Type your password in the edit box.    So that others cannot see what you type, 
asterisks will be shown in the edit box as you type.    Type carefully, because you will 
need to retype your password exactly as you type it the first time to confirm the 
password (the password is case sensitive, for example).    Click the OK button or press
the ENTER key when done.

4.    You will be prompted to retype your password.    Retype it just as you did the first 
time.    Click the OK button or press the ENTER key when done.

3.    To activate the password, click the On radiobutton beside the Set Password... 
pushbutton.    This automatically applies the password to two tasks:    opening the 
System Security... dialog box and the system lock.    You can disable the password at 
any time by clicking the Off radiobutton.

To apply the password to optional actions:

1.    Be sure you have created a password and turned it on.

2.    Click one or more of the desired check boxes in the Apply Password To section.



To protect system files:

1.    Click the Hidden or Read Only check boxes (or both) for each file you wish to protect.

NOTE:    File protection remains in effect even when you password has been turned off.

To use your password:

After you have entered a password and turned it on, whenever you start a task to which the 
password has been applied you will be prompted for the password.    If you type it wrong, the
computer will beep and you can try again.    If after three tries the correct password has not 
been entered, the task will be cancelled.    Remember, you must enter the password exactly 
as it was created -- capital letters must be entered as capitals, etc.



 Using the System Lock
On occasion, when you walk away from your desk, you may want to keep others from 
disturbing your work in a Windows application.    Easy Menu makes it possible to lock your 
Windows session with the System Lock dialog box.

To set up the System Lock:

To use the system lock you first need to enter and turn on a password in the System 
Security... dialog box.    See Using System Security for instructions on how to create and 
activate a password.

To activate the System Lock (Easy Menu must be the active window):

1.    Select Lock System! from the Options menu.    Or, if System Lock has been set up as 
one of the command buttons, click the Lock! pushbutton on the Command Bar.    You 
can also use the keyboard to activate the System Lock by pressing the PAUSE key.

To unlock your system:

1.    Once the System Lock dialog box is displayed, all other Windows processing is halted. 
When the system is locked, no Windows or DOS applications can be accessed.    To 
resume operation, enter your password in the edit box.

2. Click the OK button or press the ENTER key.



Using the Activity Log
The Activity Log records all of the applications and accessories started from Easy Menu.    It 
is a useful tool for keeping track of the work performed on your system and for diagnosing 
problems.    The Activity Log provides a date and time stamp for the following actions:    
turning on activity logging, turning off activity logging, Easy Menu start-up, auto-load and 
auto-run application start-up, menu application start-up, Quick Run command-line execution,
Windows Accessory and user accessory start-up, system locking and unlocking, starting 
Program Manager and File Manager, and quitting Easy Menu.    If an error occurs when 
attempting to start an application, Easy Menu logs a Windows execution error which you can 
use to diagnose the problem.

Activity logging is recorded in the file menu.log in the directory you specify (see Setting Up 
the Activity Log Directory).    You can view and print the log using the Windows notepad or 
any other text editor.

To start activity logging:

1.    To activate activity logging, select Activity Log from the Options Menu.

2.    Select On from the submenu.    If you have not specified a directory in which the 
activity log will be saved, a dialog box will prompt you for one.    The Activity Log 
indicator on the System Information Bar will change from red to green to remind you 
that activity logging is in use.

To stop activity logging:

1.    To stop activity logging, select Activity Log from the Options Menu.

2.    Select Off from the submenu.    The Activity Log indicator on the System Information 
Bar will change from green to red to remind you that activity logging is turned off.

To clear the activity log file:

1.    After a period of use, the activity log file may get large.    You can clear the log from 
Easy Menu.    To clear the activity log file, menu.log, select Activity Log from the 
Options Menu.

2.    Select Reset from the submenu.

3.    You will be asked to confirm whether you want to clear the log file.    Select Yes to 
clear the file or No to cancel.



Setting Up the Activity Log Directory
To specify a directory in which to save the menu.log activity file:

1.    Select Setup from the Options menu.    Select Activity Log... from the submenu.    The 
Activity Log Directory dialog box will be displayed.

2.    Enter the name of a valid directory in the edit box.    Click OK.

Note:    If you have not specified a directory prior to attempting to turn activity logging on, 
the Activity Log Directory dialog will be displayed automatically.



Exiting from Easy Menu
To exit Easy Menu:

1.    Select Exit (or Exit Windows... if Easy Menu for Windows is the system shell) from the 
File menu.    Or, if Exit has been set up as a command button, you can click the Exit 
pushbutton on the Command Bar.    If you are using the keyboard, you can just press 
the X key.

2.    If Easy Menu is the sytem shell, you will be asked to confirm that you want to exit 
your Windows session.    To exit, click the OK button.



Using the Keyboard
Easy Menu includes complete keyboard support for all functions.    Click a key below to 
review the use for each key.    (If you are not using a mouse, use SHIFT+TAB to move from 
key to key.    Press ENTER to view the use of the key.)

Note:    Keyboard support is also described in each topic where appropriate.



Easy Menu for Windows 5.0 Order Form
TO: Today's date___________

Glen S. Tittermary
P.O. Box 1641
Richmond, Virginia 23213

FROM:

Name: _______________________________________
Company: _______________________________________
Title: _______________________________________
Address: _______________________________________
City,State,Zip: _______________________________________
Country: _______________________________________
Phone Number: _______________________________________

Single user license (new license) $20.00 $________

Upgrade from earlier version (licensed users only)  $ 7.50 $________

Diskette with programs and documentation files $ 5.00 $________

Commercial site license    (Includes one diskette.)

2 to 10 computers ... $20 each:
# copies _____ x $20 $________

11 to 30 computers ... $150 for first 10, $10 each additional:
$150 + # copies over 10 _____ x $10 $________

31 or more computers . $450 for first 30, $ 7.50 each additional:
$450 + # copies over 30 _____ x $ 7.50 $________

Upgrade of site license for earlier versions:
$7.50 x ______ no. of copies licensed $________

Total Enclosed $________

Terms:    Check or Money Order drawn on a U.S.A. bank in U.S. funds. 

If ordering diskette or site license please indicate diskette format:
    5.25" disk ____        3.5" disk ____



 File Menu Commands
Quick Run...    (Alt,F,Q)
Starts an application.

Copy/Move...    (Alt,F,C)
Copies or moves a file from a source directory to a destination directory.

Delete...    (Alt,F,D)
Deletes a file.

Rename...    (Alt,F,R)
Changes the name of a file.

Create Directory...    (Alt,F,E)
Creates a new subdirectory on your hard disk.

Exit (Exit Windows...)    (Alt,F,X)
Quits Easy Menu (or Quits Windows if Easy Menu is the system shell).



Group Menu Commands
NOTE:    Only one group can be selected at a time.    The currently selected group will have a
check mark next to it.    For each instance of Group Name below, you specify a name when 
you create the group.

Group A:    Group Name    (Alt,G,A)
Selects the first group (Group A).

Group B:    Group Name    (Alt,G,B)
Selects the second group (Group B).

Group C:    Group Name    (Alt,G,C)
Selects the third group (Group C).

Group D:    Group Name    (Alt,G,D)
Selects the fourth group (Group D).

Group E:    Group Name    (Alt,G,E)
Selects the fifth group (Group E).

Edit Group Names...    (Alt,G,G)
Opens the dialog box used to enter the names of the five groups.



Menu Menu Commands
NOTE:    Only one menu can be selected at a time.    The currently selected menu will have a 
check mark next to it.    For each instance of Menu Name below, you specify a name when 
you create the menu.

Menu 1:    Menu Name    (Alt,M,1)
Selects the first menu.

Menu 2:    Menu Name    (Alt,M,2)
Selects the second menu.

Menu 3:    Menu Name    (Alt,M,3)
Selects the third menu.

Menu 4:    Menu Name    (Alt,M,4)
Selects the fourth menu.

Menu 5:    Menu Name    (Alt,M,5)
Selects the fifth menu.

Menu 6:    Menu Name    (Alt,M,6)
Selects the sixth menu.

Edit Menu Names...    (Alt,M,M)
Opens the dialog box used to enter the names of the six menus.

Print Current Menu    (Alt,M,P)
Prints the currently selected menu in the currently selected group.



Accessories Menu Commands
NOTE:  The Accessories Menu will have commands for the Windows Desktop Accessories or 
for the nine user-defined accessories based on your preference.    When user accessories are 
selected the commands will be the labels of the accessories you have set up.    When 
Windows Desktop Accessories are selected, the    commands are:

Calculator    (Alt,A,C)
Starts the Windows Calculator application.

Calendar    (Alt,A,A)
Starts the Windows Calendar application.

Cardfile    (Alt,A,D)
Starts the Windows Cardfile application.

Clipboard    (Alt,A,L)
Opens the Windows clipboard.

Clock    (Alt,A,K)
Starts the Windows Clock.

Control    (Alt,A,O)
Starts the Windows Control Panel.

Notepad    (Alt,A,N)
Starts the Windows Notepad application.

Paintbrush    (Alt,A,B)
Starts the Windows Paintbrush application.

PIF Editor    (Alt,A,I)
Starts the Windows PIF Editor.

Recorder    (Alt,A,R)
Starts the Windows Recorder application.

Terminal    (Alt,A,E)
Starts the Windows Terminal application.

Write    (Alt,A,W)
Starts the Windows Write application.



Options Menu Commands
Windows Accessories    (Alt,O,W)
Selects the Windows Desktop Accessories for the Accessories Menu and the Accessories 
Pushbutton Menu.

User Accessories    (Alt,O,U)
Selects the User Accessories for the Accessories Menu and the Accessories Pushbutton 
Menu.

Minimize on Run    (Alt,O,M)
Toggles automatic minimize on and off.    When selected, Easy Menu will minimize each time 
an application or accessory is started.    A checkmark beside this command means that 
automatic minimizing is turned on.

Activity Log >
Displays a submenu with the following commands:

On    (Alt,O,A,O)
Turns the activity log on.

Off    (Alt,O,A,F)
Turns the activity log off.

Reset    (Alt,O,A,R)
Clears the activity log file off all previous entries.

Window Position >
Displays a submenu with the following commands:

Save    (Alt,O,P,S)
Saves the current position of Easy Menu and uses the coordinates to position Easy 
Menu the next time it is started.

Center    (Alt,O,P,C)
Centers Easy Menu on the screen.

Lock System!    (Alt,O,L)
Locks Windows as a security measure.    All applications are locked until you enter your 
password.    This command will be disabled if no password has been set up and turned on.

Setup >
Displays a submenu with the following commands:

System Shell...    (Alt,O,S,S)
Displays the dialog box for setting the system shell.



Auto Start...    (Alt,O,S,A)
Displays the dialog box for setting the applications to auto-start when Easy Menu 
starts.

Command Buttons...    (Alt,O,S,C)
Displays the dialog box for setting the commands to appear on the four command 
buttons..

Managers...    (Alt,O,S,M)
Displays the dialog box for specifying alternate program, file, and task managers.

Windows Accessories...    (Alt,O,S,W)
Displays the dialog box for specifying the initial files to load when the Calendar, 
Cardfile, Notepad, Paintbrush, Recorder, Terminal, or Write Desktop Accessories are 
started.

User Accessories...    (Alt,O,S,U)
Displays the dialog box for specifying the button label and command line for the user-
defined accessories.

Activity Log...    (Alt,O,S,L)
Displays the dialog box for specifying the directory in which to write the activity log 
file.

System Security...    (Alt,O,S,T)
Displays the dialog box for specifying a password and other security options..



Help Menu Commands
Contents    (Alt,H,C)
Opens Windows Help and displays the Easy Menu Help contents page.

Keyboard    (Alt,H,K)
Opens Windows Help and displays the Easy Menu keyboard diagram.

Search for Help on...    (Alt,H,S)
Opens Windows Help and displays the Easy Menu keyword search dialog box.

How to Use Help    (Alt,H,H)
Opens Windows Help with information on how to use the Windows Help application.

System Info...    (Alt,H,I)
Displays the System Information dialog box.

About...    (Alt,H,A)
Displays the Easy Menu About dialog box.



The label is the name of the application that you want to appear next to the button in the 
menu.    The label can be up to 20 characters long.    For example, the label for Microsoft 
Excel might be MS Excel.



The command line is the executable program name and any special parameters, switches, 
or filenames to be passed to the program on start-up.

Examples: c:\winword\winword.exe
c:\winword\winword.exe letter.doc
winword.exe /mFile1



The start-up directory is the directory you want to use as the working directory when the 
application starts.    For example, if Excel is in the directory "c:\excel" but your spreadsheets 
are in "c:\data", you could specify a start-up directory as c:\data.    When Excel is started, the
"data" directory would be active (when you open or save files, for example).    The start-up 
directory is also useful for DOS programs that use configuration files, or for files that are in 
directories that have not been included in your PATH statement.



When an application is minimized it is turned into an icon.



The sytem shell is the program that runs when you first start Windows.    It is the program 
you use to start other programs and to exit from Windows.



Applications are programs you use to do work.    Microsoft Word and Excel are examples of 
word processing and spreadsheet applications.



Accessories are utility programs for special tasks.    The calendar, cardfile, and notepad 
programs shipped with Windows are examples of accessories.



A group is a collection of six menus.    In Easy Menu, you can create five groups, each with 
six menus, and each menu can have up to 10 menu items.



A menu is the collection of 10 pushbuttons and associated labels and command lines used 
to start applications.



Title Bar
At the top of the window is the title bar, which includes the name of the application, the 
Control Menu box to the left and a minimize button to the right.



Menu Bar
The menu bar has six menu items:    File, Group, Menu, Accessories, Options, and Help.



Command Bar
Below the menu bar is the Command Bar.    The Command Bar has six pushbuttons which 
can be used to execute frequently used commands.    The four command buttons at the far 
left can be configured with the commands you use most often.    Until you reconfigure the 
buttons, they will execute the Help, Lock!, Run, and Exit commands.    At the far right on 
the Command Bar are pushbuttons for starting the Windows Program Manager and File 
Manager.



System Information Display
Below the Accessories Menu is a display of various system information.    This includes the 
currently selected group and menu, the amount of free disk space for the currently selected 
drive, the amount of free system memory, and the current date and time.    The C: (or D:, E:,
etc.) button is used to select the drive to be used for the free disk space display.    The button
label will change to show the drive currently selected.



Menu Tabs
The Menu Tabs are used to select the active menu.



Accessory Tabs
The Accessory Tabs are used to select between the Windows Desktop Accessories (the w 
tab) or the user defined accessories (the u tab).



Applications Menu
The Applications Menu consists of the ten pushbuttons used to start the applications that 
you specify.    The applications are defined in the Menu Item dialog box



Accessories Menu
Below the Applications Menu is the Accessories Pushbutton Menu.    This menu is used to 
start each of the Windows Desktop Accessories or the user defined accessories.





Esc key
Closes a dialog box or cancels an action.    The same as clicking a Cancel pushbutton.



F1 - F9 Function keys
Start the user-defined accessories.    Functions keys are active only when the user 
accessories are selected for the Accessories Menu.



Pause key
Activates the System Lock.    Only active if a valid password is turned on.



1 - 0 Number keys
Start the 10 applications on the Application Menu.



Tab key
Moves the input focus from one field or pushbutton to the next in dialog boxes.



Q key
Opens the Quick Run dialog box.



W key
Starts the Windows Write accessory.    Only active if Windows accessories are selected in the 
Accessories Menu.



E key
Starts the Windows Terminal accessory.    Only active if Windows accessories are selected in 
the Accessories Menu.



R key
Starts the Windows Recorder accessory.    Only active if Windows accessories are selected in 
the Accessories Menu.



T key
Starts the Windows Task List or the alternative task manager you have specified.



I key
Starts the Windows PIF Editor accessory.    Only active if Windows accessories are selected in 
the Accessories Menu.



O key
Starts the Windows Control Panel accessory.    Only active if Windows accessories are 
selected in the Accessories Menu.



P key
Starts the Windows Program Manager or the alternative program manager you have 
specified.



A key
Starts the Windows Calendar accessory.    Only active if Windows accessories are selected in 
the Accessories Menu.



D key
Starts the Windows Cardfile accessory.    Only active if Windows accessories are selected in 
the Accessories Menu.



F key
Starts the Windows File Manager or the alternative file manager you have specified.



H key
Opens Easy Menu Help.



K key
Starts the Windows Clock accessory.    Only active if Windows accessories are selected in the 
Accessories Menu.



L key
Starts the Windows Clipboard accessory.    Only active if Windows accessories are selected in 
the Accessories Menu.



Colon key
Opens the dialog box used to select the disk drive for which to display free space in the 
System Information Display. 



Enter key
Executes an action in a dialog box.    The same as clicking an OK pushbutton.



Shift keys
Used with the 1-0 number keys to open the Menu Item dialog box used to create and edit 
items on the Applications Menu.



X key
Exits Easy Menu, or ends you Windows session if Easy Menu is the system shell.



C key
Starts the Windows Calculator accessory.    Only active if Windows accessories are selected in
the Accessories Menu.



B key
Starts the Windows Paintbrush accessory.    Only active if Windows accessories are selected 
in the Accessories Menu.



N key
Starts the Windows Notepad accessory.    Only active if Windows accessories are selected in 
the Accessories Menu.



Alt keys
Activates the Easy Menu menu bar.



Space key
Toggles between Windows Desktop Accessories and user accessories on the Accessories 
Menu.



PgUp and PgDn keys
Scrolls from the current group to the next or previous group.



Arrow keys
Scrolls from the current menu to the next or previous menu.




